Unable to log in by discourse app or safari browser iOS 12


I cannot log in on my iPad at all.

Even with adblockers desabled it just skips oauth.

I tried logging into GitHub then going back to Starling and that didn’t work.

It did work briefly in safari private mode but that’s stopped now

Weirdly it’s not happening on my iPhone. Both devices running iOS 12


Seems fine for me.

I’ve never been able to log in to Starling on the discourse app on my iPhone.

iPad works fine though.


I just got logged out on a regular browser not in the app so was forced to log in again


I have iOS12 and I cannot logon to the forums using my phone, i authenticate using facebook, authorise the app and then it goes back to the login screen. I think I heard somewhere that this is an iOS12 bug and should be fixed when a stable release comes into play.


Yep same issue now can’t login in safari either on iOS 12. Using alternative browser.


I have the same issue — authenticates successfully with Twitter but doesn’t actually log in to Starling, just loops.


Has anyone using iOS 12 got this working on the iPad at all? I’ve tried:

  • Edge
  • Firefox
  • Safari
  • Chrome

I’ve also tried them all in Incognito Mode and I have the same issue. I can authenticate against GitHub without issue but the community just loops back the front page without logging in?

It’s not a big deal as I can use my laptop and my iPhone but posting via my phone is a little bit painful if I need to post more than one sentence or correct a mistake.

p.s I also tried the Discourse App but that doesn’t work on here either (although I think this is mentioned elsewhere in community


The only browser I am logged into is ghostery it worked.


I’m logged into twitter on safari (iOS12).

I can’t log in via the discourse app though.


I’ve been using the Discourse app on both my iPhone and iPad for a while now. All logged in. No issues at all. What happens when you try?

FYI, I log in to the Starling Community via my Google account.


I’ve attempted to recreate the issue as I don’t use discourse.

I was able to login to my account using my work Google account. It seems there’s a bit of a trend happening and that everyone is on iOS 12. Has this always been an issue or only recently?


Hey @LoganAllan :wave:t3: I can’t say for definite but I think this is isolated to iOS 12 as far as I can tell. I’m unable to login on Safari or via the Discourse ‘app’ using my Twitter credentials. Is there a reason why the community has to be linked to a social network account, rather than username and password?


It was fine when I upgraded to iOS 12 with safari till I logged out.


I can’t be 100% certain, but I think I had the issue BEFORE updating to ios12.

I thought it was a Twitter/Starling/Discourse issue.


The Twitter/Community issue should have been sorted a little while ago


That is a strange one. I’ll ask around and see if there is an issue on our end



Sounds like an iOS 12 beta issue. Looks like Discourse may have attempted adding a work around 7 days ago.


Fixed in Latest Beta 4 :slight_smile:


thanks, installing now :crossed_fingers:


No change for me…

  • On iPhone I am logged in but have been this whole time. I still cannot log into Starling Bank in the Discourse App
  • On the iPad I cannot log in via the browser or the Discourse App

On a seperate note I have tried disabling service workers in Safari advanced settings. It doesn’t help


Still hasn’t been fixed for me (Twitter, iPhone X, Discourse App).

Safari is fine.