Starling for Business Feedback (iOS only)


#1

Hi,

Please use this thread to report any bugs or issues you find for Starling for Business on iOS. Please try not to report duplicates. Our known bugs or issues are as follows:

  • Account verification status showing as unexpected
  • [FIXED] Address is missing when you try to order a card
  • Can’t update address successfully. Keeps asking for passwords.
  • Statements are ordered latest (most recent) at the top. But the Interest screen is the opposite ordering, oldest (least recent) at the top.
  • Hard to differentiate cards in Apple Pay.
  • Invite to Starling page shows an error
  • Payees- briefly displays personal payees on business payees screen after you switch
  • CASS still available via scheduled payee setup
  • Ordered BCA card not displaying correctly
  • Cannot upload profile picture on the BCA
  • BCA cards are not ordering correctly. PCA card being issued instead.

#2

#3

Bug Report

iOS 11.3 - iPhone 8 Plus

If you switch to your business account and then tap “Pay”, for a split second your personal account payees show before vanishing again.


#4

Bug Report

iOS 11.3 - iPhone 8 Plus

The invite to Starling section appears to be broken.


Starling for Business Release
#5

Bug Report

iOS 11.3 - iPhone 8 Plus

Although the switch section has been removed from settings, you can still access it by tapping “Get Started” in the scheduled payments section.

This should be completely inaccessible on the business account.


#6

Bug Report

iOS 11.3 - iPhone 8 Plus

Profile picture upload appears to be broken. It just spins but doesn’t update.


#7

Will the Current Account Switch Service be available for Business accounts? I’d like to use it if possible.


#8

It’s planned for the future. It’s not available yet.


#9

Bug Report

iOS 11.3 - iPhone 8 Plus

There appears to be a card ordering bug of some kind. I ordered a card on my business account but for some reason it still says that I need to order a card.

However, my personal account is showing that a card has been ordered. :thinking:

Business Account

Personal Account


#10

Hi everyone!

Thank you for posting your feedback and bug finds. I have some news; we will be releasing a new update for the iOS app that will fix the card ordering process. Some customers were experiencing problems relating to their address and ordering the card. This should hit the app store soon.

Our team is monitoring this thread and we are taking note of all the pesky bugs that need squashing.


#11

Just tried it out - a very nice onboarding experience. I did run into one bug where requesting a CSV after a PDF gave me a PDF export instead, will try to reproduce, as managed to get a CSV in the end, so perhaps user error.

I’m wondering about export of transactions - do you have yearly statements or is it only monthly statement export at this point in order to get transactions out of Starling?


#12

We have this on the backlog @Kenny


#13

@LoganAllan I downloaded the update, status now shows as Verified but I am still getting the repeating request for my password to add my address, and so cant order my card.

Each time I open the app it keeps asking me to confirm I am a UK resident.


#14

Thanks @solster. We’ll continue to investigate.


#15

0.46.1 has landed :slight_smile:


#16

We have this on the backlog @Kenny

Excellent thanks.


#17

Got the update. Account status is still showing as Unexpected, and can’t add an address, it just puts me in an infinite loop of requesting my password.

Latest iOS, on iPhone X.


#18

Thanks @Richard_Grey - we have a process in place to address this. Have you been in contact with CS via the app? I have searched for an open ticket for you and currently can’t find anything, so just wanted to double check!


#19

I’ve also updated to latest version of app and still get the revolving password issue when trying to add address and can’t update icon/logo on personal details page highlighted above.

Have ordered card anyway and told that this will be delivered to home address (same as business address anyway).

A bug not listed above … moved some money into my new business account and didn’t receive any notification? When I logged in after a few hours the money was already showing as received. Anyone else experience this yet? Not sure if addressed in update overnight.


#20

Hi @alexandra. I logged a ticket at 10:34AM yesterday with CS. They told me that it would be resolved as a known issue, and that I would receive a notification when it was completed.

Do you want me to send you a screenshot of the chat transcript?