Pulse Not Updating First Thing In The Morning


#1

I have noticed in my first week with Starling that when I open the app first thing in the morning the Pulse screen shows the situation as at the end of the previous day. Only by pressing Home or another of the bottom icons does it reset for the day.

A bug perhaps?

I am on IPhone SE


#2

I think there are a few bugs on SE. I’ve noticed a few parts of the app are out of alignment, one already fixed and one the devs are aware of.


#3

I don’t think this is an iPhone SE thing. I’ve got an iPhone 7 and I get the same behaviour. It does this all the time for me though. If I tap a spending notification, when it takes me into the app the balance isn’t up to date. I have to manually refresh it.

Ideally the app should refresh the balance whenever you go into the app. Don’t know if this would hammer your servers though.


#4

Same problem here having to manually update on my iPhone 7 plus


#5

Interestingly this morning it was updated to zero on opening the app.


#6

Thanks for letting us know, we’ll take a look.


#7

Yeah this happens to me too, I reported it many weeks ago, still remains unfixed. iPhone 7 here.


#8

Got this first thing this morning. The Asda transaction was from yesterday morning.


#9

I’ve had this a few times, spending alerts have come through and spending tab shows the spend but pulse does not update for a few minutes or until you force close the app and re-open it.


#10

The team have been working on this one this week, expect a fix in our next release - be great to get feedback from you once that’s out.


#11

Same here, the only way I can get it to display correctly is by double click the home button (iOS) swipe away the Starling app and reopen


#12

It’s not just a morning it does this. Its at any time for me (although not checked since the update). You spend money - get a notification but pulse doesn’t update for ages - not seconds but hours sometimes.

Is this meant to be fixed now (i’ve not tried since the last update).


#13

There hasn’t been an app update since @sarah.gilbert said it would be addressed in the next update.


#14

Version 0.24.2 available in the App store now


#15

Thanks Jon. Release 0.24.2 includes updates for iOS11 :tada: The fixes for the pulse are not in that release but will be in the next one - planned for later this week.


#16

I’m impressed with the pace of releases and improvements so far :thumbsup:


#17

“Planned for later this week” so that didn’t happen then? So now when?


#18

Hello? Still waiting for an update please, still not fixed, still waiting for it to be fixed. What’s going on?


#19

I was going to raise this issue but found this thread. Is there any updates on this ?


#20

Anyone noticed that the pulse had stopped updating when you open the app since the latest update? You have to kill the app then re-open to fix? This is on latest version of IOS was fine previously