Incorrect Android Root Detection


#141

Then I am well and truly stumped :joy:


#142

Oh no… it’s back again today! Same issue as before. I changed nothing, still on 0.46.0.10505.


#143

Hi snuffy
Sorry to hear that. Glad I am keeping to LineageOS 14.1 until the problem is sorted (Hopefully)


#144

Hi all, just a quick update. We’ve followed through with some initial investigations and believe we’ve been able to successfully recreate a scenario where the device passes safetynet, running LineageOS 15.1, not rooted, but the rooted device screen appears. We’re going to continue investigating further the underlying cause of this issue, we think there is a few reasons why this could be happening and will provide further updates soon.


#145

This currently is the issue stopping me from moving to Starling.

I’m running a OnePlus One, with LineageOS unrooted, and I pass all safetynet checks, and yet Starling complains that I’m rooted. For giggles, I even tried rooting and hiding with magisk and that didn’t help.

I know it’s unlikely, but would you guys be willing to share the methods you use to detect root? I’m happy to reflash/unroot/do bootloader shenanigans to get this working for the community - I’m just not willing to buy a new phone when my One with custom firmware still works perfectly on an up-to-date OS (bear in mind, the OPO is no longer supported due to Cyanogen dropping support).

Feel free to drop me a PM if you’d like me to try something, if it helps.


#146

Hi @Makeshift,

From @AndrewPannell’s post above it sounds like they’re close to resolving this issue. Hope it’s sorted soon for you (and the many others that have been having problems with this) :+1:t2:


#147

Hello,
I am/was having the same problem.
I have rooted this phone Lenovo P2 and used custom ROMs but had to install the Lenovo original software to make it work with Google Pay.
Today I decided to join Starling and it gave the root message. I have Magisk installed and after hiding Starling still no difference.

So then I opened settings found Starling App and checked all the permissions.

Then tried and it worked, I’ve signed up.
Try that and let me know if it works for you.


#148

Hey everyone,

Our Android engineers/devs have found the issue and a fix will be released in the next Starling Android update.

Have a good one :+1:t3:


#149

The update was pushed last night, so those on Lineage should now be able to log back in :grinning:


#150

Still not working for me.


#151

Hey @ANDRE_AS

What device are you using? Are you on the latest version of the app? Are you seeing this on WiFi or 4G? Did you upgrade from 14.1 to 15.1 or completely flash from scratch? (I see that you mentioned you were on 14.1 above)

Are you able to run the checks suggested earlier on in the thread?

  • Does the device pass the Google Safety Net check?

  • What is the result of running adb shell getprop ro.secure in terminal?


#152

I am using a xiami MI-4c with latest version of starling app and latest nightly build of lineage OS 14.1 (never upgraded to 15.1). Issue occurs both in Wifi an 4G.

  • Safetynet does not pass

  • adb shell getprop ro.secure returns 0


#153

What is the best way of doing the Google Safety Net check?
I have just installed the latest version while running LineageOS 14.1 without any problem.
Reluctant to go to 15.1 until it is proven that the false root has been solved.


#154

OPO on LineageOS 15.1 nightlies here - all works fine, thanks for your time and trouble.


#155

I’m afraid if Safety Net doesn’t pass then Google doesn’t trust your device


#156

@LoganAllan, Hi, I’m still getting the rooted message on LineageOS, though updated to latest Starling Android app, and still passing both SafetyNet checks.

Could it be that there are some remnants of the old Starling app still present that I need to remove and reinstall? If so, what directories do I need to manually remove please?

I may resort to a full OS reinstall if this doesn’t work.


#157

So I’m running stock android 8.0 on my Samsung Galaxy S7 edge and getting the same “this phone is rooted” problem. I was able to setup my account and then it suddenly started doing it the other day. Glad I haven’t started using the account yet!

Android version: 8.0
Samsung Experience version: 9.0
Baseband version: G935FXXU2ERD6
Build number: R16NW.G935FXXU2EREM
App version is 0.47.0.12197


#158

Hi team
Running LineageOS 15.1 on OPO having done a few updates. Starling running OK, no root problem.

Notice that the app is slow starting up.

Thank to you all for solving this problem. Keep up the good work.


#159

I’ll get back to you on this. From my understanding the issue was resolved


#160

I think you have misunderstood. As far as I am concerned the problem has been resolved.