Error message on weekend foreign transfer screen truncated


#1

Hello Starling Support.

I’ve noticed that the in-app screen displayed at the weekends when FX markets are closed is truncated on my iPhone 6 plus…

I’m guessing that it should say ‘we can only process international transfers between Monday - Friday 08:00 - 18:00’ or similar…

-Dave


#2

Odd. Could be a device specific bug as this is how it looks on my iPhone X:


#3

@StarlingSupport possible bug here on iPhone 6 Plus. Looks fine for me on iPhone 8 Plus.


#4

Looks fine on my iPhone X


#5

It’s also showing fine on Android (on my moto g6 play.)


#6

Thanks for this. I’ll share with our in-house bug zapper, @Callum to look into! :bug: :zap:


#7

@Dave.T The text on your screenshot, including the status bar looks larger than on @Joe_Merriman’s, despite you both having Plus sized phones. (The 6 vs 8 won’t have any effect on this).

Do you happen to have your “Zoomed” mode enabled? (Settings > Display & Brightness > View).

If so, this is likely to be what is triggering the bug. Not that it’s an iPhone 6 Plus. @Callum


#8

Have just had a look on my other half’s iPhone 6 (not plus sized!) … Appears the same as the first screenshot from @Dave.T with the last line truncated.


#9

Ace, thanks @CPM. I nearly asked someone with an iPhone 6/7/8 to check as I suspected this.

So, @Callum, the issue seems to be reproducible on any iPhone 6/7/8; or on 6 Plus, 7 Plus and 8 Plus if “Zoomed” display mode is enabled (which basically shows everything the same as the non-Plus sized phone but just proportionally larger).


#10

Thanks for the replies everyone.

I’ve been able to confirm that when non-zoomed I can see the whole message… so it seems perhaps related to the zoom making the fonts and images render at a larger size leaving less room to fit the whole message in…


#11

Good news!


#12

Not really a solution… I need to use zoomed for accessibility reasons (non zoomed is too small to clearly focus for me). I’d really like someone from the Starling UI team to take a look and see what can be done.


#13

We’ll look into this in the week! :slight_smile:


#14

Thanks James


#15

Hey all!

Thanks for letting us know about this and for the device information you’ve gathered - that’s super helpful!

I’ve raised this as a bug with our engineers so it’s on our radar to fix; we’ll keep you updated on any progress. :smiley: