Android Release 0.42.0


#21

Sounds a bit like the issues I was having. All seems fine now after an initial hiccup.


#22

Have to say again, I do love the new fingerprint login screen. Much more in keeping with the Starling brand and the rest of the app :+1:t2:


#23

@sarah.guha Something I’ve noticed… have the Goals been put into alphabetical order with this release?


#24

Don’t believe so - I just created goal Z and then goal A.

Both are showing under my one original goal, which begins with U, in order of creation, even after log out / in.


#25

Mine have reordered into alphabetical order - weird!


#26

Odd indeed!

Z and A were left empty, so maybe they rearrange to alphabetical once funded…??

Can’t think of any other reason why I’d have U, Z and then A but yours are alphabetical.


#27

Mine are alphabetical and have been for as long as I can remember. I’ve added letters to them like, “A - Shopping” and “B - Fuel” and “C - Secret Dungeon Equipment”, etc etc, to put them in the order I use them, most frequent at the top.


#28

Mine too. As mentioned above it’s annoying as the goal I use most used to be at the bottom of the list and now isn’t. I’ve tried renaming it to start with Z, but it still keeps its position mid-list


#29

Mine have always been in the order they were created.


#30

I’m aware of some inconsistency with the goals order, let me check in with the team tomorrow and come back to you.


#31

Thanks @sarah.guha :+1:t2:


#33

That’s harsh and frankly untrue. The fingerprint security implementation and Android P compatibility have both been raised on this forum as needing fixing or improving. Behind the scenes, bug fixes are always important.

It may not have added new headline features, but releases aren’t always about that. Improvements to existing functionality and ensuring compatibility with upcoming OS changes are both equally valid and important.


#34

Couldn’t agree more


#35

Shouldn’t that come ahead of your shopping? :joy:


#36

Ooh Zloty is also there now…!

Never in my life did I imagine I’d have a need to send Zlotys one day…


#37

Just to let you know @sarah.guha, it appears that my existing Goals were reordered in alphabetical order but creating a new one just adds it to the end.

Incidentally, the error message in Android when creating a new Goal has been fixed in this release :slight_smile:


#38

I am not sure if it’s still the same behaviour, but when I was experimenting with this a while back it seemed that new goals were added to the end of the list (regardless of their name) but if I reinstalled the app they would be reordered alphabetically (one time) as part of this process. So this worked for me as a way to restore alphabetical order.

I did mention to CS some time back. Not sure if any development or fix has been done in this area since.