Android - Map not appearing for transactions


#1

After making a purchase at Tesco yesterday, I could view the transaction, and see the map pop up in the background. When trying to view the same transaction today, the map won’t load in. I’ve tried on both WiFi and 4G (and left it for a while), but still no joy. I also tried force closing the app, and restarting, but it’s still the same. I will go make another transaction today to see if the map comes through for that.


Transactions Not Loading
#2

Update: I uninstalled the app, reinstalled, and it’s now working as expected.

I’ll keep an eye on it to see if it reoccurs.


#3

Unfortunately this is happening again. Used it a few times today, and now the maps no longer show. I’ve just used Monzo, and the maps are appearing, so it’s not my signal.


#4

To be honest, given this and some problems in the past, l believe the app (and/or backend related to the app) is quite ‘flaky’. Whether it is fundamental issues or minor problems being overlooked, it is a little concerning.

So far, I’ve noticed some problems that have made it in the app that should never really have passed even basic user testing, and some issues that would appear to be from a lack of planning/design. I don’t know why these mistakes are being made and I have no idea what is going on behind the scenes, but I remain sceptical about the app being solid enough for everyday banking.


#5

Thanks for flagging - I’ve let the team know about this!


#6

If the team need any more info, just let me know.

Unfortunately it seems totally sporadic. You can open a transaction and the map displays. Back out and open the self same transaction, and the map/address info may or may not load. I’d say it is about a 50% failure rate at the minute.


#7

Same for me as @dave has mentioned…I’m on the latest android version…maps loading is very hit and miss. Sometimes there,sometimes not.


#8

Same issue on the latest iOS


#9

I agree, but with me it is more a 75% failure rate! It is a pain in the behind.


#10

Thanks for letting us know - we’ll pick this up with the team. @DanielWebb this might be one for you to look into.


#11

Just to jump on the back of this one, is there any chance of making the maps clickable? So that when you click on the transaction map, it takes you into Google maps (or any maps app installed) and you can zoom in/out?


#12

I am looking into this just now, it’s not something I am seeing.

I do, however, notice that the load time is a lot slower when I am on my mobile network as opposed to wifi.

Is anyone experiencing this issue when they are on wifi? Would be good to know in order to help pinpoint the cause.


#14

Mine is still hit and miss on WiFi

If I just keep going in and out of the same transaction, I can replicate it pretty easily.


#15

Also, regardless of if I’m running on WiFi or 4G, I’ve noticed Monzo’s map rendering to be a tad snappier? Not sure what it is they’re doing differently, as I’m guessing it’s just an API call? :thinking:


#16

Yes it happens when I am on both 4G and WiFi.


#17

Same here on 4g and my 4g on EE isn’t slow


#18

I have this issue on both 4G and WiFi. There’s no difference in the way it manifests on either, for me.
As with the icons vanishing. (Android 7.0 on an S8.)

Actually - I don’t know if it’s just me or if something’s changed, but the maps on entries that have them are appearing very quickly on all my transactions at the moment.


#19

Just with regard to Monzo, they are definitely doing some form of session based caching of maps. Once a particular location has been loaded, any other transactions for that same location have the maps pre-loaded when you view them. Even if you view a different location, then go back to the first one again. Seems to clear them on exit of the app though.


#20

Having a small cache for images and maps lasting around a week or month depending on how much an account is used would be fine with me.


#21

I am working with the android developers on this just now, will keep you up to date with progress. As an initial step I’ve asked for additional logging to be added so we can debug these issues. I have been struggling to replicate the issue which seems at odds with how frequently you are saying it happens.

Working hard to solve it.