Android fingerprint fail if app left open


#1

A niggly bug, easy enough to work around, but can be annoying (always happens at wrong moment)

If I open the Starling app, then background it occasionally when I go back to app it prompts for fingerprint, this then fails and it falls back to passcode with an error saying something like ‘operation cancelled’. If I close app and relaunch fingerprint works


#2

I’ve never had that problem personally.


#3

I’m on a nexus 6p on Android 8.1 seen for last few weeks (so multiple starling versions)


#4

I experience this bug almost every day and have reported it several times.


#5

I’ve tried a few times to try and replicate it to no avail.

Android 8.1

Huawei P20 Pro just for Starlings reference.


#6

I never exit the app and always just hit the home button. Never had a fingerprint failure. I wonder if it’s device(s) specific.

Xiaomi Mi Mix 2 on Oreo 8.0


#7

Your device has 8gn ram mine 3gb. Maybe starling into a different state sooner on my device due to this. It could also be an 8.0 Vs 8.1 thing


#8

Google Pixel 2 XL running Android 8.1 Oreo. It’s pretty much as @mwarby said - it appears to be when you’re using the app, then go off and use some other app(s), when you return to the Starling app it asks for your fingerprint then immediately fails. You then have to armed the option to use your PIN instead, which lets you in.

Never had a fingerprint issue in any other app. This issue has existed since the changes to the fingerprint login screen.


#9

Not sure if it helps, but when user this get the green fingerprint icon not red(which I get if I try and use the wrong finger) so something at some level knows the fingerprint is good


#10

I can actually reproduce it now, but worse

Go to develoer settings, select Don’t keep activities, toggle this on. Now open starling app and try to sign in, fingerprint will fail first time and ask for passcode

Note I don’t normally have this setting on, as it causes issues with many apps,just tried it for debugging now


#11

If that’s a reply to me, mine has 6gb. For some reason it’s not showing who the reply was to.

I wouldn’t know if it was introduced with the new sign in screen, as with the old sign in fingerprint wasn’t supported on Huawei or Xiaomi devices. Since the new sign in Xiaomi fingerprint works and I cannot reproduce the behaviour you guys are seeing.

Maybe it is an 8.0 Vs 8.1 thing


#12

too add to the mystery. With ‘Don’t keep activities’ on sign in using passcode will fail first time with 'sign in failed, fingerprint operation cancelled, use passcode. If I select use passcode that works.


#13

screencap

Device: Huawei Nexus 6P
Android Version: 8.1.0

Replicated this with the above mentioned method.


#14

Thank you for highlighting this error with the app and sorry this has not been resolved as of yet @danmullen

I’ll pick this up with @Callum tomorrow and raise this with our engineers.

I hope we can resolve this as quickly as possible.

Many thanks,


#15

Thanks @Oliver_Wright. As I mentioned, the problem first started occurring after the changes to the login screen some months ago.


#16

Hi @mwarby,

Thanks for letting us know about this :slight_smile:

We’ve put a fix in place which will be included in the next release of the app.

Once that’s live, please give this another go and let us know how you get on!