Android app issues and poor support


#1

I’ve been with Starling for quite some time now, and apart from some minor issues the app has functioned adequately in the main.

I’m using an android device on Marshmellow.

Over the course of the last week or so the app does the following.

1.) Tells me I’m using a new device and I have to go through the set-up process all over again.
2.) I’m unable to login to the app as after 3 digits of passcode entry as the app tells me the PIN is incorrect (I’ve used the same passcode each time, after I’ve had to reset the device - it works for 24 hours or so then the PIN error gets displayed or the app advises I’m logging in from a new device).
3.) The app shows I have two devices authorised now - but they are the same device?
4.) When i try to read notifications I get a 403 not authorised message.
5.) I’m using version 0.41.2.5999 of the starling app (strange versioning control?)

Using the Chat help is not to be recommended to anyone, the agent ability seems to be woefully inadequate for anything beyond the most basic of account questions. I suspect this is an outsourced service, or judging by the responses I was getting the other day, a BOT.

I must be costing Starling a fortune as sometimes I have to request the SMS code 5 or 6 times before it arrives after 10 minutes or so, and this can be 8 or 9 times a day.

The issue was apparently passed to the development team on the 04th of May, but I’m still waiting for resolution.

I’ve spent well over 5 hours in chat sessions and on the phone trying to resolve this issue.

Starling just isn’t ready for the real world yet. I really am sad to say that with the card acceptance issues and others, Starling is a vanity / novelty project. You certainly couldn’t expect to run on only a Starling account.

My business account has been functioning in the main OK. But I simply can’t risk 8 days without business banking, so back to Tide for that, which I had kept running in case this sort of senario occurred.

I have recommended Starling to a number of people. But with the exception of one they all had issues either with the sign-up process, phones acceptability issues or app issues. It seems Starling is pushing away it’s customer base in quite a startling way.


#2

Thank you for raising your concerns and sorry to hear of the sequence of events. We will arrange for one of our CS team to give you a call regarding the ongoing issues which you have experienced with the linking of your Business account. All of our support team are 100% human and all part of the team here, we’ll certainly look to review all of the circumstances and try our best to help get this one sorted! :slightly_smiling_face:


#3

I’m surprised to hear this - I’ve been using Starling for the last six months and recently switched all of my banking over. Apart from a couple of minor issues everything has been great.

Hope you get a resolution to your issues soon :+1:t2:


#4

The recent issue I have had with false root detection has made me realise likewise, that having no alternate channel for account control or resolution is a major shortfall of this business model.

I have asked for all my funds to be xferred out and supplied my number to the support team for someone to call to verify my identity but two days and one reminder later I still haven’t had a call.

I have been a promoter of the service, and think the use of AWS, use of DevOps to ensure speedy delivery of change and lack of legacy infrastructure to maintain is a very big advantage over traditional banks. And the app, when it works, beats most if not all of its competitors for user experience.

Unfortunately I can no longer hand on heart continue to recommend. It is a cliché but bad news does travel faster than good news, and when lost it is difficult to regain customer trust.

Prove me wrong Starling and push out a release (or revert) to fix the recent app new and rooted device flaw that was in the latest release. And going forward recognise that as you are a single channel bank you need to properly test releases across a wider range of device emulators - I realise androids heavily scattered device specific and multiple patch levels make it much harder to test than iOS (and make sure you have a blackout plan if a release is seriously flawed). Especially and critically when it comes to features that will prevent access to existing customers.

I so want Starling to succeed but this latest Android update has shown a lack of maturity in the release process, that has impacted customers during such an important period of customer growth and brand building for the bank.


#5

If this is important to you it might be worth looking at Starlings competition like Monzo.


#6

I considered Monzo when I opened my Starling account but was swayed by the commission and fee free oversees use on Starling.

As Monzo also only have an app plus webapi but no true secondary channel I fear they too could fall fowl of similar issues. I will take a look at their support forums and do a bit of digging about their release and testing process before jumping from the frying pan into the fire. :grinning:


#7

We’ll arrange for one of our CS team to give you a call and get this looked into for you. :slightly_smiling_face:


#8

Thanks very much for contacting me and arranging for the funds to be transferred out.

Hopefully when the device identification issues are resolved I will be able to resume use of the bank account.


#9

Fingers crossed any issues will be sorted ASAP.


#10

Hi Oliver,

Thanks for reaching out on this issue. You explanation yesterday made a lot of sense and in that it did account for the issue around not being able to view both my personal and business accounts on a single device. I’m happy in the short term to wait and see if this will be resolved.

However I’m still getting the app passcode PIN issue. The workaround for this currentlyis to stop the app from the apps menu. Go through the device verification process again, then I will get access for about 24 hours (sometimes less).

I have tried using ‘Device Security’ instead, this allows me to enter my pattern, then the app promptly crashes, but on the up side, when I restart the app it goes straight in to the process of setting up my account again, enter my phone number, getting the verification code, entering my password, select to use ‘Device Security’ and I’m in for that session, without having to bother to go into my device settings to stop the app, back to home screen, start the app and then following all the other above steps, so a handy feature of the app.

When I’m in, I’m still seeing 2 devices authorised (under ‘Manage Devices’). Both being the current device. One dated with my original account sign-up and the other dated with that current sessions date.

Next to the original device is a menu option glyph / icon (3 vertical dots). But this has no action.

Every time I go to attempt to make a payment, I’m presented with the ‘Settle Up’ slider. I click on the cross glyph top left. Slider is removed. Next payment attempt I get it again. This really is very annoying, I only need to see it once, not every time I attempt to make a payment.

13/05/18 - trying to make a payment. I get “Service is currently unavailable”. However the Starling website shows ALL services as ‘Operational’ (I’ve knowingly experienced this since since 12/05/2018). So how am I supposed to make payments to friends for my share of a meal? Wait let me guess… I should use ‘Settle Up’? I’d much rather just use my bank, in which I have the friend set up as a payee, and doesn’t involve me having to set any thing up. Oh and they don’t have a phone that can install an app.

Once again, this ‘single point of failure’ with only the app, is the Achilles heal of Starling. This needs to have 99.999999999 availability time for every user.

I am able to top-up goals, so depending on how the app works, there would appear to be a current connection to Starling (I’m getting the current balance etc) and at least the ‘Goals’ service is apparently working (although there is no specific ‘Goals’ status to check).

So, having first reported issues on 04/05/2018 on the 13/052018 I am still not operating on a functioning banking service.

I think it’s time somebody put a rocket up the rear end of the developers to resolve these issues. Given the protracted time-frame I’d have expected a resolution to some of these issues by now.

At one point I was told no progress had been made because they were awaiting details from me, which had been sent to my notifications, which I had already reported I couldn’t view as it generated a 403 Not Authorised http response when trying to view them. But had provided in a previous ‘Chat’ session. Support needs to get joined up pronto.

I’ll keep updating this topic as and when issues get resolved. and at least with a ‘No progress’ post.

I am hopeful that now Oliver has taken ownership of my issues that come COP monday I’ll have something positive to report.


#11

18:08 - So to update on this issue.
Oliver has called this morning to advise that a Lead developer had been tasked to address the issues, but they are complex.
However as at writing all issues remain, and I’m still unable to make payments, so can’t pay credit cards that were due, or repay a friend waiting for me to settle up a meal. This is very embarrassing now.

In addition I have a regular saver account that requires a payment each month to pay interest at the end of the year, but can’t make payments to that either.

I can’t even transfer any funds to a working Halifax account, because payments don’t work.

I have signed up for Monzo, (although Monzo would still seem to suffer from the solo channel, single point of failure that Starling has created for itself) but the app tells me I’m in the queue of 76,830 still waiting to get setup.


#12

It takes around 2 days to a week to get through the queue.
People in this thread will probably be able to help you skip it altogether:

Hopefully your issues will be resolved soon.


#13

Hi @MrRobot, Many thanks for the Golden Ticket heads up. Looks like someone else already used that ticket.

I’ve been in a chat session with ‘Callum’ tonight, who really was an excellent CS agent, so was able to make my payments at last!

He advised the other issue should be resolved tomorrow with some luck.

I’ll wait an see what happens with Monzo, but for the time being I’m heading back to Halifax, who although sh8te always managed to keep the lights on.


#14

I’ve just sent you a Golden Ticket mate :+1:t2:


#15

I can appreciate it when people mention support and the chat.

Point in case is just now:

I specifically asked about if an advanced replacement is possible and I’ve bascially just got a canned response back. Try and reply and the chat has put me back in the queue and then ended the chat!

The number of negative CS experiences that are being posted on here recently is quite alarming. I have another if my own but I think there’s enough examples out there right now.


The good and bad side of mobile based banking
#16

Hey @Chalky and everyone who has raised our chat time out issues.
This has been escalated to our chat provider in the past, and today we received a potential fix.
Our android and iOS devs are understanding how to implement this to get it in quickly. We still need to test it before we get it out.
I agree, it is frustrating for you (and us too).
Really sorry for this.


The good and bad side of mobile based banking
#17

Thanks @patrick, unfortunately that doesn’t address the not great response to my quite specific question though.


#18

A new card once ordered can be added to Apple Wallet straight from the app (before you receive the new physical card).

Right now we can’t pre-order replacement cards, although this is a really good idea.

If you haven’t already had a response in app, you’ll get one shortly.


#19

So i’ve also had similar issues, whenever I try to login to the app it basically requires me to reverify my phone/account, it seems to work once I get in, but it doesn’t last, even when I login & out, & back in again moments later the same thing occurs, i’m running android though im not sure what OS i’m using, I tried calling but I just got told to leave a message, clearly this is not just an issue for me though, any idea when it will be fixed? it only started today for me


#20

Thanks for the clarification. I did get a reply back but unfortunately was just a copy and paste of what I’d already had.

I’ve bent my card back and hopefully it’ll work :crossed_fingers: